読者です 読者をやめる 読者になる 読者になる

peketaminの日記

その辺のプログラマーです。うーむ…。

SublimeText3 では SublimeLinter-flake8 が動かないので Atom + linter-flake8 に乗り換えた

Atom.

前に試した時はバージョンアップ時やアンインストール時に ~/.atom が変に残ったりして、使用を中止した。

今回、 Atom に乗り換えるまでは SublimeText3 + Python-flake8-Lint だった。これはよく動いた。 しかし、Python-flake8-Lint の方は、 PyCharm ほど警告が厳しくなく、 例えば、 import 挿入箇所や順序についての警告が出なかった (設定次第?)

で、表題の通り SublimeLinter の方を期待してスイッチを試みたが、動かないことがわかった (SublimeText2なら動くらしい)

なので、軽量モダンエディタとして今まで大変 SublimeText にお世話になってきたのだが、これからは Atom を試していきたいと思う。

Vim の設定は相変わらず、前にマシンを再セットアップした際に vimrc を捨ててから進んでない。 が、そのうち、充実させて github に反映したい心算なり也。